Production Maintenance: V25.12.2 Patch Deployment (Feb 24, 2026)
Resolved
Feb 24, 2026 at 05:44am UTC
Deployment has been completed, all services are up and running
Affected services
Created
Feb 24, 2026 at 04:30am UTC
We will conduct scheduled maintenance to deploy patch V25.12.2 in the production environment on February 24, 2026. Applications will remain fully operational, and no customer impact is expected.
Affected services